Thursday, January 04, 2007

We're sorry. This blog is only viewable with (insert random internet tech) enabled.

What is it with websites that only work in Internet Explorer, or use JavaScript, or ActiveX, or some other technology? I mean, it isn't bad enough they don't just work, they also don't tell you what to do to fix the problem. A few examples:

"This website only works with JavaSript enabled. You are using an ancient browser that doesn't support them. Too bad!"

It should say this:

"This website works best with JavaScript enabled. Use the non-JavaScript version, or download FireFox 2, a free browser that works."

"This website uses ActiveX controls. You don't have a browser that supports them. Get lost!"

It should say:

"This website uses an obsolete piece of technology that Microsoft won't resign. Your browser doesn't support ActiveX. If you are using FireFox 2, you can download a free extension that allows ActiveX to run. Also, click here to tell our idiot developers that they need to upgrade the website design so it doesn't rely on a leaky piece of software that hackers use to break your computer."

Now, was that so hard?

Labels: ,

0 Comments:

Post a Comment

<< Home